请问 屏幕 应该怎么设置?

装好sid之后发现不能调节亮度, 进到设置里面发现 显示和色彩都不能用,没有搜到相关问题,是不是这个问题太简单了, 安装的 gnome-core ,还是少装了什么包?


执行以下指令将结果全部复制贴上来

ls /sys/class/backlight/
cat /sys/class/backlight/*/brightness
lspci -knn | grep -iA2 "vga\|3d\|disp"

新建用户还是有这个问题

[quote]
执行以下指令将结果全部复制贴上来

ls /sys/class/backlight/ cat /sys/class/backlight/*/brightness lspci -knn | grep -iA2 "vga\|3d\|disp" [/quote]

执行以下指令将结果全部复制贴上来

cat /sys/class/dmi/id/{sys_vendor,product_name}

尝试将亮度数值写入 /sys/class/backlight/intel_backlight/brightness 看有无实际效果

尝试使用下列任意一组内核参数
acpi_backlight=vendor
acpi_osi=Linux
acpi_backlight=vendor acpi_osi=Linux
video.use_native_backlight=1(此参数无效, 见 forums.debian.net/viewtopic.php?p=595183#p595183 )

使用 acpi_backlight=vendor 后再查看 /sys/class/backlight/ 下有无出现与厂商有关的亮度界面。若出现了,则 gnome 应该会优先使用。(根据 bugzilla.kernel.org/show_bug.cgi?id=50551#c13 的说法,不知现在有无改变)

===============
附增加内核参数方法

1 - 临时增加
开机到 GRUB 界面时,按 e 进入编辑界面
在 ‘linux’ 一行末尾增加内核参数。看起来像这样:ro splash acpi_backlight=vendor
按 Ctrl+x 启动

2 - 永久增加
编辑 /etc/default/grub 在 GRUB_CMDLINE_LINUX_DEFAULT 中增加内核参数
看上去类似这样:
GRUB_CMDLINE_LINUX_DEFAULT="ro splash acpi_backlight=vendor"
保存后执行 update-grub

[quote]执行以下指令将结果全部复制贴上来

cat /sys/class/dmi/id/{sys_vendor,product_name} [/quote]

shu@debian:~$ cat /sys/class/dmi/id/{sys_vendor,product_name}
LENOVO
20312

[quote]尝试将亮度数值写入 /sys/class/backlight/intel_backlight/brightness 看有无实际效果

[/quote]

这样有效果

[quote]尝试使用下列任意一组内核参数
acpi_backlight=vendor
acpi_osi=Linux
acpi_backlight=vendor acpi_osi=Linux
video.use_native_backlight=1

使用 acpi_backlight=vendor 后再查看 /sys/class/backlight/ 下有无出现与厂商有关的亮度界面。若出现了,则 gnome 应该会优先使用。(根据 bugzilla.kernel.org/show_bug.cgi?id=50551#c13 的说法,不知现在有无改变)

===============
附增加内核参数方法

1 - 临时增加
开机到 GRUB 界面时,按 e 进入编辑界面
在 ‘linux’ 一行末尾增加内核参数。看起来像这样:ro splash acpi_backlight=vendor
按 Ctrl+x 启动

2 - 永久增加
编辑 /etc/default/grub 在 GRUB_CMDLINE_LINUX_DEFAULT 中增加内核参数
看上去类似这样:
GRUB_CMDLINE_LINUX_DEFAULT="ro splash acpi_backlight=vendor"
保存后执行 update-grub[/quote]

出现了一个ideapad 在gnome中还是不能设置
内核参数 splash 的位置显示的是quiet

谢谢v大 :wink: 我再去gnome社区找找看

分别在使用/不使用 acpi_backlight=vendor 情况下在 “System Settings” -> “Brightness & Lock” 中通过滑块(有无滑块?)设置亮度。看看亮度是否变化?
若亮度变化,则可能为热键问题。

参见 github.com/GNOME/gnome-settings-daemon/blob/master/plugins/power/gsd-backlight-linux.c#L62
g-s-d 挑选亮度界面的顺序为 firmware -> platform -> raw
三种类型例
firmware: acpi_video*
platform: ideapad
raw: intel_backlight
根据楼上测试,ideapad, intel_backlight 均无法被 g-s-d 使用,解决起来可能不太顺畅。

是否考虑测试其它桌面环境?

[quote=“vickycq”]

分别在使用/不使用 acpi_backlight=vendor 情况下在 “System Settings” -> “Brightness & Lock” 中通过滑块(有无滑块?)设置亮度。看看亮度是否变化?
若亮度变化,则可能为热键问题。

参见 github.com/GNOME/gnome-settings-daemon/blob/master/plugins/power/gsd-backlight-linux.c#L62
g-s-d 挑选亮度界面的顺序为 firmware -> platform -> raw
三种类型例
firmware: acpi_video*
platform: ideapad
raw: intel_backlight
根据楼上测试,ideapad, intel_backlight 均无法被 g-s-d 使用,解决起来可能不太顺畅。

是否考虑测试其它桌面环境?[/quote]

以前是能用的,使用过xfce4,kde,也全都可以用,这个宿舍今天断网了,这里的网络特别奇怪,没断网之前开着ss在电脑上面也登不上Google和telegram,访问中科大源和上海交大源的速度只有每秒几十KB,所以我打算过几天回学校用教育网重新装一次,到时候再看看能不能被g-s-d使用。
谢谢v大教我怎么解决这个问题 :smiley: