debian9能够安装kodi18吗?

如题,是不是什么版本的debian就得安装对应什么版本的kodi?请教大家

按照kodi官方wiki:https://kodi.wiki/view/HOW-TO:Install_Kodi_for_Linux
来看的话,Debian linux上安装的最佳方式就是Apt install kodi了。但是很可惜,根据debian官网软件包查询结果来看,debian9也好debian10也罢,kodi版本都是17.x版本(debian9是kodi 17.1,debian10是kodi 17.6)都不是kodi 18.x版本。
可参考
https://packages.debian.org/search?keywords=kodi&searchon=names&suite=all&section=all

从这个网页不难看出,哪怕是最激进的debian sid版本,kodi依旧是17.6。

如果一定要kodi 18.x版本,只能老老实实切换到ubuntu。Ubuntu下,通过添加PPA,可以安装最新的18.5版本。kodi官方wiki上也写了步骤:
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get install kodi

按照这些步骤,即可在ubuntu上安装最新版kodi.

如果对其他发行版感兴趣,其他发行版也有提供kodi18.x版本的。我查到的结果如下:

arch linux:自己的仓库提供kodi 18.5
manjaro linux:因为基于Arch,因此自己的仓库里面也有kodi 18.x版本。
Fedora31:添加rpm fusion后提供kodi 18.4版本。
mageia 7.1:自带的软件仓库提供kodi 18.2
openSUSE Leap15.1:添加packman源后提供kodi18.5
linux Mint:因为基于ubuntu LTS,因此必须跟Ubuntu操作步骤一样添加PPA才能获取到kodi 18.5

以上就是怎么获取到kodi18.x的办法了。

谢谢答复使我有了更多的了解。原来以为sudo apt-get install kodi就可以安装最新版的kodi了,看来不是那回事啊!我是为了安装omv4和omv5做nas系统,然后在这系统上安装kodi做兼有HTPC功能。现在还有一个情况就是不能安装pvr iptv simple client这个插件!不知道如何安装

同样也可以参考一下官方wiki:https://kodi.wiki/view/Add-on:IPTV_Simple_Client 希望帮到你吧。

看不懂啊,好像没有安装的方法

debian9 安装kodi18.x的话,可以用flatpak:
https://www.flathub.org/apps/details/tv.kodi.Kodi

这个要怎么安装啊?有没有相关中文介绍?

这两天等我给你写个~

好的,非常感谢!这个debian10也可以用的把?

Stretch:
1、添加stretch-backports源 然后 sudo apt update
2、sudo apt install flatpak gnome-software-plugin-flatpak(这个用于gnome)
3、flatpak install flathub tv.kodi.Kodi

完成.
debian10一样。

我安装的是Openmediavault系统,然后再加了lxde和kodi,设置自动登录kodi作为影音播放系统的!就是nas+kodi,像我这是lxde桌面的又是如何安装了啊?请教

OpenMediaVault我没用过,如果安装包可以用apt的话,那么lxde也可以按上面的命令安装,只不过不用安装gnome-software-plugin-flatpak,没有这个表示只能命令行来弄。

编辑文件 /etc/apt/sources.list
sudo vi /etc/apt/sources.list
添加如下配置
deb http://deb.debian.org/debian stretch-backports main contrib non-free

更新 apt
sudo apt update
安装软件
sudo apt install flathub tv.kodi.Kodi

是不是这样操作啊?

sudo apt update 之后:
1、sudo apt install flatpak
2、flatpak install flathub tv.kodi.Kodi

Note that the directories

‘/var/lib/flatpak/exports/share’
‘/root/.local/share/flatpak/exports/share’

are not in the search path set by the XDG_DATA_DIRS environment variable, so
applications installed by Flatpak may not appear on your desktop until the
session is restarted.

Looking for matches?
error: No remote refs found similar to ?.lathub?

安装不了,出现这个,是什么回事?

不用sudo也提示这个么?

flatpak install flathub tv.kodi.Kodi 用的第二条命令啊

我估计和你的系统有关,没用过你那个系统;我用的是Debian Stretch;
不知道这里有哪位懂这个错误提示的,来给讲讲~