debian9.4.0无法安装网易音乐云1.1.0


(裸男子) #1

root@debian:/opt# dpkg -i netease-cloud-music_1.1.0_amd64_deepin.deb
正在选中未选择的软件包 netease-cloud-music。
(正在读取数据库 … 系统当前共安装有 147586 个文件和目录。)
正准备解包 netease-cloud-music_1.1.0_amd64_deepin.deb …
正在解包 netease-cloud-music (1.1.0) …
dpkg: 依赖关系问题使得 netease-cloud-music 的配置工作不能继续:
netease-cloud-music 依赖于 libqcef1;然而:
未安装软件包 libqcef1。
netease-cloud-music 依赖于 libqt5qml5 (>= 5.0.2);然而:
未安装软件包 libqt5qml5。
netease-cloud-music 依赖于 libqt5sql5 (>= 5.0.2);然而:
未安装软件包 libqt5sql5。
netease-cloud-music 依赖于 libqt5webchannel5 (>= 5.6.1);然而:
未安装软件包 libqt5webchannel5。
netease-cloud-music 依赖于 libqt5xml5 (>= 5.0.2);然而:
未安装软件包 libqt5xml5。

dpkg: 处理软件包 netease-cloud-music (–install)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 gnome-menus (3.13.3-9) 的触发器 …
正在处理用于 desktop-file-utils (0.23-1) 的触发器 …
正在处理用于 mime-support (3.60) 的触发器 …
正在处理用于 hicolor-icon-theme (0.15-1) 的触发器 …
在处理时有错误发生:
netease-cloud-music


#2

普通用户请勿再使用旧式的 dpkg -i 命令安装任何 deb 软件包,因 dpkg 无法自动处理依赖。

请使用 apt install ./xxxxxx.deb 安装,可以自动处理依赖。


#3

关于apt的这个用法其实我一直想说,为什么非要用户加上前面的./呢,这个体验不是很好


#4

或许可以给开发者提个小建议去掉这个限制


(Pirate) #5

sudo apt -f install


(FindHao) #6

推荐用gdebi