How to add fcitx Pinyin input method?

I followed the below tutorial to install fcitx

su
insert debian 8.6.0 dvd
apt-get install fcitx
apt-get install fcitx-sunpinyin
im-config

on internet tutorial says
When asked if you want to explicitly update the user preferences, select “Yes”, then select fcitx as the default input method framework in the dialogue which pops up. Log off and back on again, or better yet, reboot.You should now see a keyboard icon in your system tray in the upper right corner of your screen.

and I get
GtkDialog mapped without a transient parent. This is discouraged.I can’t see fcitx on upper right corner of your screen.Could you tell me what’s wrong?

仍然不知道你在用什么桌面环境。我只能猜你是 GNOME 用户。

首先请在重启系统后命令行运行 fcitx-diagnose 命令进行排错,并按照其指示进行修复。

其次,对于 GNOME 用户,可以考虑前往 extensions.gnome.org 安装 Kim Panel,可以获得更加良好的体验。

[code]# System Info:

  1. uname -a:

    Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u1 (2016-09-03) x86_64 GNU/Linux
    
  2. lsb_release -a:

    No LSB modules are available.
    Distributor ID:	Debian
    Description:	Debian GNU/Linux 8.6 (jessie)
    Release:	8.6
    Codename:	jessie
    
  3. lsb_release -d:

    Description:	Debian GNU/Linux 8.6 (jessie)
    
  4. /etc/lsb-release:

    /etc/lsb-release not found.

  5. /etc/os-release:

    PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
    NAME="Debian GNU/Linux"
    VERSION_ID="8"
    VERSION="8 (jessie)"
    ID=debian
    HOME_URL="http://www.debian.org/"
    SUPPORT_URL="http://www.debian.org/support"
    BUG_REPORT_URL="https://bugs.debian.org/"
    
  6. Desktop Environment:

    Desktop environment is gnome3.

Environment:

  1. DISPLAY:

    DISPLAY=':0'
    
  2. Keyboard Layout:

    1. setxkbmap:

      xkb_keymap {
      	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
      	xkb_types     { include "complete"	};
      	xkb_compat    { include "complete"	};
      	xkb_symbols   { include "pc+us+cn:2+us:3+inet(evdev)"	};
      	xkb_geometry  { include "pc(pc105)"	};
      };
      
    2. xprop:

      _XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us,cn,us", ",,", ""
      
  3. Locale:

    1. All locale:

      C
      C.UTF-8
      en_HK.utf8
      POSIX
      
    2. Current locale:

      LANG=en_HK.UTF-8
      LANGUAGE=en_HK:en
      LC_CTYPE="en_HK.UTF-8"
      LC_NUMERIC="en_HK.UTF-8"
      LC_TIME="en_HK.UTF-8"
      LC_COLLATE="en_HK.UTF-8"
      LC_MONETARY="en_HK.UTF-8"
      LC_MESSAGES="en_HK.UTF-8"
      LC_PAPER="en_HK.UTF-8"
      LC_NAME="en_HK.UTF-8"
      LC_ADDRESS="en_HK.UTF-8"
      LC_TELEPHONE="en_HK.UTF-8"
      LC_MEASUREMENT="en_HK.UTF-8"
      LC_IDENTIFICATION="en_HK.UTF-8"
      LC_ALL=
      
  4. Directories:

    1. Home:

      /root
      
    2. ${XDG_CONFIG_HOME}:

      Environment variable XDG_CONFIG_HOME is not set.

      Current value of XDG_CONFIG_HOME is ~/.config (/root/.config).

    3. Fcitx Settings Directory:

      Current fcitx settings directory is ~/.config/fcitx (/root/.config/fcitx).

  5. Current user:

    The script is run as root (0).

    1. sudo Environment Variables:

      SUDO_COMMAND is not set.

      SUDO_USER is not set.

      SUDO_UID is not set.

      SUDO_GID is not set.

    2. Running as root:

      You are probably logging in as root or using sudo to run this script. This either means you have security problems or the result of this script may not be accurate. See Why is it bad to run as root or sudo environment variables for more information.

Fcitx State:

  1. executable:

    Found fcitx at /usr/bin/fcitx.

  2. version:

    Fcitx version: 4.2.8.5

  3. process:

    Found 3 fcitx processes:

     1026 fcitx <defunct>
     1032 fcitx
     1057 fcitx-dbus-watc
    
  4. fcitx-remote:

    Cannot connect to fcitx correctly.

Fcitx Configure UI:

  1. Config Tool Wrapper:

    Found fcitx-configtool at /usr/bin/fcitx-configtool.

  2. Config GUI for gtk2:

    Config GUI for gtk2 not found.

  3. Config GUI for gtk3:

    Found fcitx-config-gtk3 at /usr/bin/fcitx-config-gtk3.

  4. Config GUI for kde:

    kcmshell4 not found.

Frontends setup:

Xim:

  1. ${XMODIFIERS}:

    Environment variable XMODIFIERS is “@im=ibus” instead of “@im=fcitx”. Please check if you have exported it incorrectly in any of your init files.

    Please set environment variable XMODIFIERS to “@im=fcitx” using the tool your distribution provides or add export XMODIFIERS=@im=fcitx to your ~/.xprofile. See Input Method Related Environment Variables: XMODIFIERS.
    If you are using gnome>=3.6, you may want to uninstall ibus, remove ibus-daemon or use the command gsettings set org.gnome.settings-daemon.plugins.keyboard active false to disable IBus integration in order to use any input method other than ibus. See Note for GNOME Later than 3.6 for more detail.

    Xim Server Name from Environment variable is ibus.

  2. XIM_SERVERS on root window:

    Xim server name is the same with that set in the environment variable.

Qt:

  1. qt4 - ${QT4_IM_MODULE}:

    Environment variable QT4_IM_MODULE is “xim” instead of “fcitx”. Please check if you have exported it incorrectly in any of your init files.
    You are using xim in qt4 programs.

    To see some application specific problems you may have when using xim, check Hall of Shame for Linux IME Support. For other more general problems of using XIM including application freezing, see here.

    Please set environment variable QT4_IM_MODULE to “fcitx” using the tool your distribution provides or add export QT4_IM_MODULE=fcitx to your ~/.xprofile. See Input Method Related Environment Variables: QT4_IM_MODULE.

  2. qt5 - ${QT_IM_MODULE}:

    Environment variable QT_IM_MODULE is “ibus” instead of “fcitx”. Please check if you have exported it incorrectly in any of your init files.
    You may have trouble using fcitx in qt5 programs.

    Please set environment variable QT_IM_MODULE to “fcitx” using the tool your distribution provides or add export QT_IM_MODULE=fcitx to your ~/.xprofile. See Input Method Related Environment Variables: QT_IM_MODULE.

  3. Qt IM module files:
    Cannot find fcitx input method module for Qt4.
    Cannot find fcitx input method module for Qt5.

Gtk:

  1. gtk - ${GTK_IM_MODULE}:

    Environment variable GTK_IM_MODULE is “xim” instead of “fcitx”. Please check if you have exported it incorrectly in any of your init files.
    You are using xim in gtk programs.

    To see some application specific problems you may have when using xim, check Hall of Shame for Linux IME Support. For other more general problems of using XIM including application freezing, see here.

    Please set environment variable GTK_IM_MODULE to “fcitx” using the tool your distribution provides or add export GTK_IM_MODULE=fcitx to your ~/.xprofile. See Input Method Related Environment Variables: GTK_IM_MODULE.

  2. gtk-query-immodules:

    1. gtk 2:

      Cannot find gtk-query-immodules for gtk 2

      Cannot find fcitx im module for gtk 2.

    2. gtk 3:

      Cannot find gtk-query-immodules for gtk 3

      Cannot find fcitx im module for gtk 3.

  3. Gtk IM module cache:

    1. gtk 2:

      Found immodules cache for gtk 2.24.25 at /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache.
      Version Line:

      # Created by /usr/lib/x86_64-linux-gnu/libgtk2.0-0/gtk-query-immodules-2.0 from gtk+-2.24.25
      

      Failed to find fcitx in immodule cache at /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache

      Cannot find fcitx im module for gtk 2 in cache.

    2. gtk 3:

      Found immodules cache for gtk 3.14.5 at /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache.
      Version Line:

      # Created by /usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 from gtk+-3.14.5
      

      Failed to find fcitx in immodule cache at /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache

      Cannot find fcitx im module for gtk 3 in cache.

  4. Gtk IM module files:

    1. gtk 2:

      All found Gtk 2 immodule files exist.

    2. gtk 3:

      All found Gtk 3 immodule files exist.

Configuration:

Fcitx Addons:

  1. Addon Config Dir:

    Found fcitx addon config directory: /usr/share/fcitx/addon.

  2. Addon List:

    1. Found 15 enabled addons:

      fcitx-autoeng
      fcitx-chttrans
      fcitx-clipboard
      fcitx-dbus
      fcitx-freedesktop-notify
      fcitx-fullwidth-char
      fcitx-imselector
      fcitx-ipc
      fcitx-keyboard
      fcitx-punc
      fcitx-quickphrase
      fcitx-remote
      fcitx-spell
      fcitx-sunpinyin
      fcitx-unicode
      
    2. Found 0 disabled addons:

  3. Addon Libraries:

    All libraries for all addons are found.

  4. User Interface:

    Cannot find enabled fcitx user interface!

Input Methods:

  1. Found 0 enabled input methods:

  2. Default input methods:

    You don’t have any input methods enabled.

Log:

  1. date:

    Fri Oct 21 10:10:52 HKT 2016
    
  2. ~/.config/fcitx/log/:

    total 0
    
  3. ~/.config/fcitx/log/crash.log:

    ~/.config/fcitx/log/crash.log not found.[/code]

I will fingure out later,if anyone can help me I will very appreciated.thank you

中间的说明已经很清楚了,我怀疑你 im-config 没有配置好。

再次配置一遍 im-config,然后重启,然后按照 fcitx-diagnose 的提示做一遍,再重启,如果还是老样子就把 ibus 卸载掉再重启再用 im-config 配一遍再重启,还有问题的话继续按照 fcitx-diagnose 的提示进行修复。说到底就是那些环境变量不对。

另外使用 root 用户的桌面环境是强烈不推荐的,很多图形界面程序都很可能出问题。请以普通用户的身份使用桌面。

另外,你的 locale 也设置为 en_HK,这会造成一些输入法的问题。如果问题一直无法解决,请将 locale 设置为 zh_CN.UTF-8 再试。这样可以把系统切换到中文环境。

when I use im-config,I click OK on this window and window closed

[code]Setting the user configuration /home/liujianwei/.xinputrc to fcitx.
Manual configuration selects: fcitx
Flexible Input Method Framework (fcitx)

  • Required for all: fcitx
  • Language specific input conversion support:
    • Simplified Chinese: fcitx-pinyin or fcitx-sunpinyin or fcitx-googlepinyin
    • Generic keyboard translation table: fcitx-table* packages
  • Application platform support:
    • GNOME/GTK+: fcitx-frontend-gtk2 and fcitx-frontend-gtk3 (both)
    • KDE/Qt4: fcitx-frontend-qt4

The user configuration is modified by im-config.

Restart the X session to activate the new user configuration.
If a daemon program for the previous configuration is re-started by the X session manager, you may need to kill it manually with kill(1).
See im-config(8) and /usr/share/doc/im-config/README.Debian.gz for more.[/code]

I used su to enter root,I quited su now.

I don’t know how to change locale,please help me,thank you

[quote=“cuthead”]when I use im-config,I click OK on this window and window closed

[code]Setting the user configuration /home/liujianwei/.xinputrc to fcitx.
Manual configuration selects: fcitx
Flexible Input Method Framework (fcitx)

  • Required for all: fcitx
  • Language specific input conversion support:
    • Simplified Chinese: fcitx-pinyin or fcitx-sunpinyin or fcitx-googlepinyin
    • Generic keyboard translation table: fcitx-table* packages
  • Application platform support:
    • GNOME/GTK+: fcitx-frontend-gtk2 and fcitx-frontend-gtk3 (both)
    • KDE/Qt4: fcitx-frontend-qt4

The user configuration is modified by im-config.

Restart the X session to activate the new user configuration.
If a daemon program for the previous configuration is re-started by the X session manager, you may need to kill it manually with kill(1).
See im-config(8) and /usr/share/doc/im-config/README.Debian.gz for more.[/code]

I used su to enter root,I quited su now.

I don’t know how to change locale,please help me,thank you[/quote]

我现在安装了fcitx-frontend-gtk2后可以输入中文但是无法输入英文了,也无法选词,请教应该怎么办?

[quote=“cuthead”]1. Home: /root
2. Running as root:[/quote]

楼上的 fcitx-diagnose 使用 root 身份运行,结果无意义。需使用普通用户身份运行。

建议直接安装 fcitx-frontend-all

在 fcitx-config-gtk3 中确认 “Input Method” 选项卡中除中文输入法外还包含 “Keyboard - English(US” 且处于首位

建议更详细描述问题。可在终端中杀死并重启 fcitx 收集输出。

执行fcitx-configtool后可以按ctrl-space切换中英文但仍然无法取词,请教应该怎么办?
root@debian:/home/liujianwei# apt-get install fcitx-frontend-all
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package fcitx-frontend-all is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘fcitx-frontend-all’ has no installation candidate

root@debian:/home/liujianwei# fcitx-config-gtk3
无法添加任何输入法

liujianwei@debian:~$ killall fcitx
liujianwei@debian:~$ fcitx
liujianwei@debian:~$ (INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-keyboard.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-imselector.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-fullwidth-char.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-dbus.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-spell.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-ipc.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-clipboard.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-quickphrase.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-chttrans.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-remote-module.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-autoeng.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-punc.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-unicode.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-freedesktop-notify.conf
(INFO-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-sunpinyin.conf
(ERROR-2018 /tmp/buildd/fcitx-4.2.8.5/src/lib/fcitx/ui.c:165) no usable user interface.

确保软件源正确配置并刷新软件包列表

使用 root 身份运行,无意义。需使用普通用户身份运行

能否显示取词框?

[quote=“vickycq”]

确保软件源正确配置并刷新软件包列表

使用 root 身份运行,无意义。需使用普通用户身份运行

能否显示取词框?[/quote]

请教如何配置软件源并刷新软件包列表?
普通用户身份运行fcitx-config-gtk3显示Keyboard和Wubi
使用此命令后
aptitude install -y fcitx fcitx-ui-classic fcitx-tools fcitx-table-wubi fcitx-table-cangjie5 fcitx-table fcitx-table-all fcitx-pinyin fcitx-module-x11 fcitx-frontend-all fcitx-frontend-gtk2 fcitx-frontend-gtk3 fcitx-frontend-qt4
可以使用五笔后不太需要取词框但仍然无法显示并且想知道如何显示取词框

以使用清华大学开源软件镜像站为例。将 /etc/apt/sources.list 中相关条目全部替换为以下内容。保存后执行 apt-get update

[code]deb http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie main contrib non-free

deb http://mirrors.tuna.tsinghua.edu.cn/debian-security jessie/updates main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian-security jessie/updates main contrib non-free

deb http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie-updates main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie-updates main contrib non-free
[/code]

根据进一步透露的信息,猜测问题为无法显示取词框,与有无 “Keyboard - Englisch(US)” 无关。亦非之前猜测的“可以显示取词框,但按数字键取词失败”

先确保 fcitx 相关的包已装全。我这里已安装的包如下
特别注意 fcitx-module-dbus, fcitx-ui-classic

$ dpkg -l | grep fcitx | awk '{print $2}' fcitx fcitx-bin fcitx-config-common fcitx-config-gtk fcitx-data fcitx-frontend-all fcitx-frontend-gtk2 fcitx-frontend-gtk3 fcitx-frontend-qt4 fcitx-libpinyin fcitx-module-cloudpinyin:amd64 fcitx-module-dbus fcitx-module-kimpanel fcitx-module-lua fcitx-module-x11 fcitx-modules fcitx-mozc:amd64 fcitx-pinyin fcitx-table fcitx-table-wbpy fcitx-table-wubi fcitx-ui-classic libfcitx-config4:amd64 libfcitx-core0:amd64 libfcitx-gclient0:amd64 libfcitx-qt0:amd64 libfcitx-utils0:amd64

[quote=“vickycq”]

以使用清华大学开源软件镜像站为例。将 /etc/apt/sources.list 中相关条目全部替换为以下内容。保存后执行 apt-get update

[code]deb http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie main contrib non-free

deb http://mirrors.tuna.tsinghua.edu.cn/debian-security jessie/updates main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian-security jessie/updates main contrib non-free

deb http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie-updates main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie-updates main contrib non-free
[/code]

根据进一步透露的信息,猜测问题为无法显示取词框,与有无 “Keyboard - Englisch(US)” 无关。亦非之前猜测的“可以显示取词框,但按数字键取词失败”

先确保 fcitx 相关的包已装全。我这里已安装的包如下
特别注意 fcitx-module-dbus, fcitx-ui-classic

$ dpkg -l | grep fcitx | awk '{print $2}' fcitx fcitx-bin fcitx-config-common fcitx-config-gtk fcitx-data fcitx-frontend-all fcitx-frontend-gtk2 fcitx-frontend-gtk3 fcitx-frontend-qt4 fcitx-libpinyin fcitx-module-cloudpinyin:amd64 fcitx-module-dbus fcitx-module-kimpanel fcitx-module-lua fcitx-module-x11 fcitx-modules fcitx-mozc:amd64 fcitx-pinyin fcitx-table fcitx-table-wbpy fcitx-table-wubi fcitx-ui-classic libfcitx-config4:amd64 libfcitx-core0:amd64 libfcitx-gclient0:amd64 libfcitx-qt0:amd64 libfcitx-utils0:amd64 [/quote]

非常感谢v大,现在已经有取词框了。这是我已安装的fcitx包

fcitx fcitx-bin fcitx-config-common fcitx-config-gtk fcitx-data fcitx-frontend-all fcitx-frontend-gtk2:amd64 fcitx-frontend-gtk3:amd64 fcitx-frontend-qt4:amd64 fcitx-frontend-qt5:amd64 fcitx-libs:amd64 fcitx-libs-gclient:amd64 fcitx-libs-qt:amd64 fcitx-libs-qt5:amd64 fcitx-module-dbus fcitx-module-x11 fcitx-modules fcitx-pinyin fcitx-sunpinyin fcitx-table fcitx-table-all fcitx-table-bingchan fcitx-table-cangjie fcitx-table-cangjie5 fcitx-table-dianbaoma fcitx-table-erbi fcitx-table-wanfeng fcitx-table-wbpy fcitx-table-wubi fcitx-table-ziranma fcitx-tools fcitx-ui-classic

可否分享一下采取了何种措施?

[quote=“vickycq”]

可否分享一下采取了何种措施?[/quote]

好的可以v大

su vi /etc/apt/sources.list a

[code]deb http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie main contrib non-free

deb http://mirrors.tuna.tsinghua.edu.cn/debian-security jessie/updates main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian-security jessie/updates main contrib non-free

deb http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie-updates main contrib non-free
deb-src http://mirrors.tuna.tsinghua.edu.cn/debian/ jessie-updates main contrib non-free [/code]

shift-insert apt-get update apt-get install fcitx-module-dbus apt-get install fcitx-ui-classic aptitude install -y fcitx fcitx-ui-classic fcitx-tools fcitx-table-wubi fcitx-table-cangjie5 fcitx-table fcitx-table-all fcitx-pinyin fcitx-module-x11 fcitx-frontend-all fcitx-frontend-gtk2 fcitx-frontend-gtk3 fcitx-frontend-qt4 fcitx-config-gtk3 im-config

刚刚重新安装了Debian 8.6.0,选择中文安装,在光盘中使用网络镜像,选择KDE,在线安装等待了一段时间,安装好了后显卡驱动nouveau又恢复了,而且一开始拼音输入法就弄好了。

fcitx install
fcitx-bin install
fcitx-config-common install
fcitx-config-gtk install
fcitx-data install
fcitx-frontend-all install
fcitx-frontend-gtk2:amd64 install
fcitx-frontend-gtk3:amd64 install
fcitx-frontend-qt4:amd64 install
fcitx-frontend-qt5:amd64 install
fcitx-googlepinyin install
fcitx-libs:amd64 install
fcitx-libs-gclient:amd64 install
fcitx-libs-qt:amd64 install
fcitx-libs-qt5:amd64 install
fcitx-module-dbus install
fcitx-module-kimpanel install
fcitx-module-lua install
fcitx-module-x11 install
fcitx-modules install
fcitx-pinyin install
fcitx-sunpinyin install
fcitx-table install
fcitx-table-wubi install
fcitx-ui-classic install
kde-config-fcitx install

today I use the same method,except set debian locale as unite states.I use below command in terminal.

apt-get update apt-get install fcitx fcitx-table-wbpy fcitx-config-gtk fcitx-config-gtk3
I have used fcitx-config-gtk3,add input method,but it shows nothing.
I don’t know why this happened.please help me.