noip client 无法自动启动,小白第一次用script, 没有反应, 手动没有问题!

已解决

#1

安装了noip client,运行正常,也可以手动启动。
在/etc/init.d下建了一个noip的script文件,内容按readme说明如下,存入文件名为noip

#######################################################
#! /bin/sh
# . /etc/rc.d/init.d/functions # uncomment/modify for your killproc
case “$1” in
start)
echo “Starting noip2.”
/usr/local/bin/noip2
;;
stop)
echo -n “Shutting down noip2.”
killproc -TERM /usr/local/bin/noip2
;;
*)
echo “Usage: $0 {start|stop}”
exit 1
esac
exit 0
#######################################################

系统为Debian 9
重新启动debian以后,noip client 没有启动,手动启动 /usr/local/bin/noip2,一点问题也没有,
放错地方了?缺了什么设置?需要在哪里额外的设置?请指点!
谢谢!:grinning:


#2

在网上查了一下,做了以下的动作,但还是没有进展

  1. chmod 755 /etc/init.d/noip
  2. update-rc.d noip defaults
    没有报错信息
    但/etc/rcN.d下面没有相应的文件,所以重新启动以后也没有执行noip2

(虫二) #3

因爲你的腳本裏沒有指定 Default,所以用 update-rc.d noip defaults 是沒效果的,用 update-rc.d noip enable 就好了。
不過 Debian 9 的話,推薦用 systemd 吧,創建 /etc/systemd/system/noip2.service,內容:

[Unit]
Description=No-ip.com dynamic IP address updater
After=network.target
After=syslog.target

[Install]
WantedBy=multi-user.target
Alias=noip.service

[Service]
# Start main service
ExecStart=/usr/local/bin/noip2
Restart=always
Type=forking

然後 sudo systemctl enable noip2 就好了。

(以上 noip2.service 內容來自 Systemd Service file for no-ip.com dynamic ip updater


#4

成功了!
非常感谢!!!
:+1:t2::+1:t2::+1:t2: