libgtk2.0-dev安装错误


(Pirate) #1
   The following packages have unmet dependencies:
   libgtk2.0-dev : Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
             Depends: libxcursor-dev but it is not going to be installed

#2

apt update 的输出和 apt policy libgtk2.0-dev 的输出和 aptitude install libgtk2.0-dev 的输出和 sources.list 的内容都发上来


(Pirate) #3

apt update

http://paste.debian.net/1013172/

apt policy libgtk2.0-dev

http://paste.debian.net/1013173/

aptitude install libgtk2.0-dev

The following NEW packages will be installed:
  gir1.2-gtk-2.0{a} libatk1.0-dev{a} libcairo-script-interpreter2{a} 
  libcairo2-dev{a} libgdk-pixbuf2.0-dev{ab} libgraphite2-dev{a} 
  libgtk2.0-dev libharfbuzz-dev{a} libharfbuzz-gobject0{a} 
  libpango1.0-dev{a} libpixman-1-dev{a} libxcb-render0-dev{a} 
  libxcb-shm0-dev{a} libxcomposite-dev{a} libxcursor-dev{ab} 
  libxdamage-dev{a} libxinerama-dev{a} libxrandr-dev{a} 
  x11proto-composite-dev{a} x11proto-damage-dev{a} x11proto-randr-dev{a} 
  x11proto-xinerama-dev{a} 
0 packages upgraded, 22 newly installed, 0 to remove and 0 not upgraded.
Need to get 7,024 kB of archives. After unpacking 32.6 MB will be used.
The following packages have unmet dependencies:
 libxcursor-dev : Depends: libxcursor1 (= 1:1.1.14-1+b4) but 1:1.1.14-1+deb9u1 is installed
 libgdk-pixbuf2.0-dev : Depends: libgdk-pixbuf2.0-0 (= 2.36.5-2+deb9u1) but 2.36.5-2+deb9u2 is installed
                        Depends: gir1.2-gdkpixbuf-2.0 (= 2.36.5-2+deb9u1) but 2.36.5-2+deb9u2 is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libgdk-pixbuf2.0-dev [Not Installed]               
2)     libgtk2.0-dev [Not Installed]                      
3)     libxcursor-dev [Not Installed]                     


Accept this solution? [Y/n/q/?]  

cat /etc/apt/sources.list

http://paste.debian.net/1013174/


#4

我的建议是,你可以添加 stretch 的安全更新源,然后 apt update 后再试;若仍然存在问题,请添加 stretch proposed updates 源然后更新后再试。

请尝试上面两个建议,然后再把结果发一遍上来。


#5

基本可以确定你的问题在于没有启用安全更新源却启用了 stretch updates 源。请务必在所有 Debian 稳定版系统上启用安全更新源。


(Pirate) #6

问题解决了,可否讲解一下问题是怎么解决的?


#7

tracker.debian.org 上看了看对应缺失的新版来自哪里,发现它们在安全更新和 proposed-updates 中均存在,故添加缺失的源即可解决问题。


(Pirate) #8

谢谢,受教。