Lightdm在输入帐户前会闪一下,如何解决

debian testing,在登录界面上,lightdm会闪一下屏幕。求解。

优先考虑是否正确安装/设定显卡驱动
执行以下指令将结果全部复制贴上来

uname -a
cat /etc/issue
lspci -knn | grep -iA2 "vga\|3d\|disp"
find /etc/ | grep xorg.conf | xargs head -n -0

类似问题 参考
bugs.launchpad.net/lightdm-gtk-greeter/+bug/1531224
bbs.archlinux.org/viewtopic.php?id=206657

[code]Linux debian 4.7.0-1-amd64 #1 SMP Debian 4.7.8-1 (2016-10-19) x86_64 GNU/Linux
Debian GNU/Linux stretch/sid \n \l

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
Subsystem: Lenovo 4th Gen Core Processor Integrated Graphics Controller [17aa:221d]
Kernel driver in use: i915

02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208M [GeForce GT 730M] [10de:1290] (rev a1)
Subsystem: Lenovo GK208M [GeForce GT 730M] [17aa:221d]
Kernel modules: nvidia
==> /etc/bumblebee/xorg.conf.nouveau <==
Section "ServerLayout"
Identifier "Layout0"
Option “AutoAddDevices” "false"
Option “AutoAddGPU” "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver “nouveau”

If the X server does not automatically detect your VGA device,

you can manually set it here.

To get the BusID prop, run lspci | egrep 'VGA|3D' and input the data

as you see in the commented example.

This Setting is needed on Ubuntu 13.04.

BusID “PCI:01:00:0”

EndSection

==> /etc/bumblebee/xorg.conf.nvidia <==
Section "ServerLayout"
Identifier "Layout0"
Option “AutoAddDevices” "false"
Option “AutoAddGPU” "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName “NVIDIA Corporation”

If the X server does not automatically detect your VGA device,

you can manually set it here.

To get the BusID prop, run lspci | egrep 'VGA|3D' and input the data

as you see in the commented example.

This Setting may be needed in some platforms with more than one

nvidia card, which may confuse the proprietary driver (e.g.,

trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.

BusID "PCI:02:00:0"

Setting ProbeAllGpus to false prevents the new proprietary driver

instance spawned to try to control the integrated graphics card,

which is already being managed outside bumblebee.

This option doesn’t hurt and it is required on platforms running

more than one nvidia graphics card with the proprietary driver.

(E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).

If this option is not set, the new Xorg may blacken the screen and

render it unusable (unless you have some way to run killall Xorg).

Option "ProbeAllGpus" "false"

Option "NoLogo" "true"
Option "UseEDID" "false"
Option "UseDisplayDevice" "none"

EndSection

==> /etc/bumblebee/xorg.conf.d <==

==> /etc/bumblebee/xorg.conf.d/10-dummy.conf <==

==> /etc/X11/xorg.conf <==

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 352.79 (buildd@debian) Wed Apr 27 14:07:29 UTC 2016

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice “Keyboard0” "CoreKeyboard"
InputDevice “Mouse0” "CorePointer"
EndSection

Section "Files"
EndSection

Section “InputDevice”
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option “Protocol” "auto"
Option “Device” "/dev/psaux"
Option “Emulate3Buttons” "no"
Option “ZAxisMapping” "4 5"
EndSection

Section “InputDevice”
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "intel"
Option “Backlight” "intel_backlight"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

==> /etc/X11/xorg.conf.nvidia-xconfig-original <==
[/code]

[quote=“加勒比海带”]
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
Subsystem: Lenovo 4th Gen Core Processor Integrated Graphics Controller [17aa:221d]
Kernel driver in use: i915[/quote]

可考虑参考楼上参考链接,尝试令 intel 集显使用 uxa 加速。或有副作用。

/etc/X11/xorg.conf.d/20-intel.conf

Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "uxa" EndSection

[quote=“vickycq”]

[quote=“加勒比海带”]
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
Subsystem: Lenovo 4th Gen Core Processor Integrated Graphics Controller [17aa:221d]
Kernel driver in use: i915[/quote]

可考虑参考楼上参考链接,尝试令 intel 集显使用 uxa 加速。或有副作用。

/etc/X11/xorg.conf.d/20-intel.conf

Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "uxa" EndSection[/quote]

不行,我还是继续用slim吧